The "generation" of programmers that learned their craft sometime after C reached its zenith of popularity. Idiomatic C often shortens identifiers by dropping vowels (for example, ''strcmp'', ''setjmp'', and ''memcpy''. This is less common in later languages like Java--in fact, TheElementsOfJavaStyle proscribes this practice explicitly. ---- One of the style points in the little Java book of CodingStandard''''''s ("The Elements of Java Style"): Don't drop vowels when shortening names. Of course, they go so far as to say, don't shorten names, but I just darn well think that Id is just as good as Identity. Shortening names by dropping vowels makes things incredibly hard to type. I can type Request''''''Builder almost twice or better as fast as I can type Rqst''''''Bldr. -- JeffBay ------ At least from a grammatical point of view, "Id" != "ID". The former is a psychological term; the latter is the 'correct' abbreviation for "Identity". ''Since when are abbreviations capitalized? It is not an acronym.'' -- Jim ''I agree from a grammatical point of view, but from a NamingConvention point of view, sometimes the commonly accepted case of words needs to be modified for readability. I prefer to use either strict camelCasing or strict Pascal''''''Casing. If I had a database ID column for XML data, I could name it "XMLDataI''''''D", or "XmlDataI''''''d". Even though the latter is not the accepted casing if the words are broken out, when jammed together it makes things much nicer on the eyes. -- mattmc3'' ---- I guess it is time for the next mission of Operation Vowel Storm after its successes at Grzny. --EricJablow ''Gurnzey, isn't that a small island off the British coast line?'' Operation Vowel Storm: http://www.ijmc.com/archives/1996/January/02January1996.html That's reprinted (without credit) from the original story at TheOnion. * Alternate link with attribution, http://www.avdf.com/feb96/humour_vowels.html copyright 1995 by TheOnion ---------- I'm against it as an "always do" rule. Verbosity and excessively long names also slows down reading and code comprehension, at least for my WetWare. There is a middle ground between the two extremes, and naming well is an art that requires skill, experience, and sound judgement. Further, code comments can be used to explain names at the point of declaration such that the object name does not have to carry the entire burden of explaining itself. RelationalDatabaseFieldNames gives some examples. ---- See also RelationalDatabaseFieldNames ------ CategoryNaming